bug in pclose(3)
Eric Gisin
egisin at mks.UUCP
Sat Jan 7 02:39:38 AEST 1989
In article <803 at auspex.UUCP>, guy at auspex.UUCP (Guy Harris) writes:
> Since "waitfor()"/"wait4()" does things that "waitpid()" doesn't
> (namely, optionally fill in a "struct rusage"), I see no reason why the
> people at Berkeley would want to rename "wait{4|for}" to "waitpid".
> They may want to provide "waitpid" as a procedure that calls
> "wait{4|for}", but that's a different matter.
Declare waitpid as
pid_t waitpid (pid_t pid, int *statp, int options, ...);
#define WRUSAGE 0x10
The option WRUSAGE can indicate that a fourth parameter
pointing to a struct rusage exists.
There's no need for half-a-dozen wait-like functions in 4.4 BSD.
More information about the Comp.unix.wizards
mailing list