Adding additional HardDisk to Xenix
Jonathan Bayer
jbayer at ispi.UUCP
Sat Oct 28 23:55:33 AEST 1989
bob at consult.UUCP (Bob Willey) writes:
>We are attempting to add an additional hard disk to our system.
>We currently have a Seagate ST4096 drive, and are going to add
>a Miniscribe 3085. I understand about formating, and
>What we want to be able to do, is to move
>/u /wp (WordPerfect areas) and /usr/spool/news
>areas to the new drive and allocate space for them.
>How do we specify these areas correctly, and how
>do we move files over easily. I understand that if we
You are going to have to create three filesystems on the new drive, one
for each of the major directories you want to move over. The following
steps should do it for you:
0. ***** BACKUP YOUR SYSTEM *****
1. Determine the amount of space you want to allocate to each of
the directories.
2. Rename the current directories /u and /wp to /u.old and /wp.old
3. Do a mkdev hd and create the new file systems. When you get
into divvy you will have to enter the appropriate values for
each new filesystem. The values will include the beginning and
ending locations on disk, as well as the filesystem names. You
will also have to set the "New File System" flag. I have
included the divvy table from my third disk as an example:
+---------------+------------------+---+-------------+------------+
| Name | New File System? | # | First Block | Last Block |
| news | no, exists | 0 | 0| 20000|
| archives | no, exists | 1 | 20001| 41011|
| | no | 2 | -| -|
| | no | 3 | -| -|
| | no | 4 | -| -|
| | no | 5 | -| -|
| | no | 6 | -| -|
| de057all | no, exists | 7 | 0| 41470|
+---------------+------------------+---+-------------+------------+
41012 blocks for divisions, 459 blocks reserved for the system
n[ame] Name or rename a division.
c[reate] Create a new file system on this division.
p[revent] Prevent a new file system from being created on this division.
s[tart] Start a division on a different block.
e[nd] End a division on a different block.
r[estore] Restore the original division table.
Please enter your choice or `q' to quit:
4. Perform the following commands to setup the new filesystems:
mkdev fs /dev/u /u
mkdev fs /dev/wp /wp
mkdev fs /dev/news /news
5. Mount each filesystem as follows:
mount /dev/u /u
mount /dev/wp /wp
mount /dev/news /news
6. Copy the data in the old directories onto the new filesystems:
copy -omvr /u.old /u
copy -omvr /wp.old /wp
copy -omvr /usr/spool/news /news
(these commands will copy all directories, setting the
permissions and owners correctly)
7. Unmount the new filesystems:
umount /dev/u
umount /dev/wp
umount /dev/news
8. Remove the directories /u and /wp
9. Rename the directories /u.old and /wp.old to /u and /wp
10. Remove all the data in each directory:
cd /u; rm -fr *
cd /wp; rm -fr *
cd /usr/spool/news; rm -fr *
11. Modify /etc/default/filesys to make the line for the news
filesystem mount it on /usr/spool/news:
bdev=/dev/news mountdir=/usr/spool/news rcmount=yes fsckflags=-y
12. Reboot your system and verify that all the filesystems are being
mounted correctly.
--
Jonathan Bayer Intelligent Software Products, Inc.
(201) 245-5922 500 Oakwood Ave.
jbayer at ispi.COM Roselle Park, NJ 07204
More information about the Comp.unix.wizards
mailing list